Back to overview
Mulesoft Issues
Apr 25, 2025 at 3:43pm UTC
Affected services
Achieve
Resolved
Apr 25, 2025 at 3:43pm UTC
We're aware of issues connecting to Mulesoft and are working on it
Update: We restarted the system and all services are working
Affected services